2012年7月6日星期五

如何使用W7100A實現Telnet伺服器(一)


这篇文档将会介绍Telnet以及使用iMCU7100EVB来实现Telnet服务器。除了连接到iMCU。用户可以用Telnet来控制LEDs。在第二章我们简单地介绍一下Telnet,第三章将会演示Telnet函数的具体功能,第四章将涉及到代码的分析。这篇文档中所有的示例代码都是基于Keil uVision3。


1.这里我们先分享前面部分,希望对大家有所帮助。


2. Telnet
Telnet是用于因特网或者局域网的网络协议,它可以为设备间提供一个双向的交互式通信。Telnet起源于RFC15,于1969年发展起来,随后开始标准化。带有TCP/IP协议栈的网络设备基本都支持Telnet服务。Telnet是一个广泛用于客户端/服务器的应用程序。
由于越来越多具有便捷功能浏览器的出现,Telnet的重要性逐渐降低。但是telnet对于众多用于远程连接的多用户电脑来说,仍然是一个很重要的工具;用户可以从住处、工作地点或者任何地方通过因特网连接到telent服务器。


图 2.1Telnet系统

2.1 NVT (网络虚拟终端)
对于用户来说,远程连接Telnet服务器的过程比较复杂。由于电脑将接收的特殊字符组合作为一个标记;同时根据OS的不同,这个特殊字符的组合也会不同,因此Telnet定义了一个NVT来解决这个问题。通过使用NVT,Telnet客户端将本地终端输入的字符组合转换成NVT格式,然后发送到网络。Telnet服务器将接收到的NVT格式字符转换成远程电脑可以接收和读取的格式。这个过程如下图2.2所示。


图2.2Telnet系统的NVT

NVT使用了两类字符组合;一个是用于数据,另外一个是用于远程控制。
用于数据的NVT通常使用NVT ASCII。NVT ASCII是一个8位的字符组合;较低7位与美国的ASCII相同,最高位为0。当最高位是1时,必须提前定义并在Telnet客户端和服务器之间的进行协商。
用于远程控制的NVT利用一个最高位置为1的8位控制字符。当发送用于进入特殊键的远程控制字符,设置连接和改变状态之前,先发送使用TCP的IAC(中断命令,值为0xFF)。因此,在IAC字符后接收到的字节会被看作远程控制字符。

表2.1NVT控制字符



控制字符
值
释义
EOF
236
文档结束
EOR
239
记录结束
SE
240
次选项结束
NOP
241
无操作
Data Mark
242
同步信道的数据流部分。这个应该带有一个TCP紧急通知。
Break
243
NVT 字符BRK
Interrupt Process
244
暂停,中断,终止或者结束与NVT连接的进程。同时,用于TELNET的其它协议的的部分外频信号都可能发生中断进程。
Abort output
245
允许当前的进程(出现)运行完成,但是不发送给用户它的输出。同时,向用户发送同步信道。
Are You There
246
回送给NVT一些可见的(例如:可打印的) 证据证明AYT接收到
Erase character
247
接收端应该从数据流中删除上一个之前未删除字符或者“打印位置”。
Erase Line
248
接收端一个删除数据流回送来的字符,但是不包括,上一个通过TELNET连接发送来的“CR LF”序列。
Go ahead
249
GA信号
SB
250表示接下来的是指示选项的次协商。
WILL
251表示开始执行的目的,或者确认你正在执行,指示选项。
WONT
252表示拒绝执行,或者继续执行,指示选项。
DO
253表示其它部分执行的请求或者确认你希望其它部分执行,指示选项。
DON’T
254表示要求其它部分停止执行,或者确认你不再希望其它部分执行,指示选项。
IAC
255中断命令。

2.2 用于Telnet终端的选项
正如之前提到的,客户端和服务器之间的选项能够在使用Telnet服务时进行协商。下表中显示了一些通用选项。
表2.2telent选项
选项ID
名称
备注
1
回显(Echo)
RFC857
3
抑制前进(Suppress go ahead)
RFC858
5
状态(Status)
RFC859
6
时序标记(Timing mark)
RFC860
24
终端类型(Terminal type)
RFC1091
31
窗口大小(Window size)
RFC1073
32
终端速度(Terminal speed)
RFC1079
33
远程流控制(Remote flow control)
RFC1372
34
行模式(Line mode))
RFC1184
36
环境变量(Environment variables)
RFC1408

在使用Telnet选项时必须用到客户端和服务器之间的协商选项。如表2.1所示,4个控制字符(WILL、WONT、DO以及DONT)用于选项协商。
为了能够激活选项,发送端发送WILL命令,询问“可以激活该选项吗?”然后,接收端将会发送DO命令,表示接受,或者DONT命令,表示拒绝。另外一种激活选项的方法是发送DO命令,表示“激活该选项”,并且接收端回送WILL命令或者WONT命令。
使选项无效的过程如下。发送端发送WONT命令,表示“不再使用该选项”。然后,接收端将会回送DO命令接受或者DONT命令拒绝。

图2.3telnet选项协商

2.3 Telnet操作模式
大多数Telnet的操作执行有三种模式:普通模式(General mode)、字符模式(Character mode),以及行模式(Line mode)。
-普通模式(General mode):这是选项协商在不选择字符或者行模式时最基本的模式。在这种模式下,回送所有的输入字符,直到一行完成才发送。
在向服务器发送完所有的行后,客户端等待GA命令直到一个新的行被接受。如果TCP连接是全双工的, 那么这种模式就是无效的,因为一般的Telnet工作于半双工模式。
-字符模式(Character mode): 当客户端输入字符时,每一个字符都被发送给服务器。服务器允许回送字符显示在客户端的屏幕上。在这种模式下,当回送字符的传输太慢时,可能会发生一些延时;此时,将会增加网络的负荷。
-行模式(Line mode): 一般情况下,建议使用行模式(Line mode),它可以覆盖普通模式(General mode)和字符模式(Character mode)的缺点。在这种模式下,用户的行编辑(回送,删除字符,删除行等等)都是可以的。在行被编辑完成后,发送给服务器。行模式以全双工模式执行,并且所有行可以不需要GA命令即被发送。

好了,这就是我们今天的内容,后续部分我们将尽快发布,谢谢关注。



如果您有任何疑问,请直接留言或登录WIZ net官方网站:http://www.wiznettechnology.cn/
或者来电:86-10-84539974(转166),QQ:2377211388,
邮箱:wiznetbj@wiznettechnology.com 联系人:Jerry ,谢谢!

2012年7月5日星期四

WIZnet員工 2012培訓筆記——WIZ220IO網頁流覽器演示


WIZ220IO网页浏览器演示过程 


首先把电源连接DC5V适配器,把D - SUB9此连接器是一个UART连接到电脑。
最后模块上的LAN端口连接到电脑。

打开配置工具,它可通过以太网进行的偏远地区支持以下主要功能配置工具。
- 更改模块的配置。
- I/O控制
- 固件上传
- 网页上传

再来是更改模块的网络配置,通讯协议
假设这里的IP地址是192.168.1.50

打开网页浏览器,输入的IP地址192.168.1.50



在左圖中,8个开关控制每一个数字输入端口(Digital Input ports)。当你打开开关,数字端口信号将是低的。结果显示在网页浏览器上。
在右圖中,8个LED显示每个数字输出端口(Digital Output ports)。端口的信号是低电时,LED灯被打开。结果显示在网页浏览器上。


你可以控制可变电阻模拟量输入(Analog input)。该WIZ220IO的模拟输入电压类型,其范围是0V到VCC(5V)。此外,它的值转换为0〜4095,为每一个输入端口具有12位分辨率。
通孔的模拟输出(Analog Output),用户应用程序,它可以连接到外部设备。每个端口的输出电压等级的价值,和输出电压范围是0〜4V“。最大输出值是4095生成4V水平。



如果您有任何疑问,请直接留言或登录WIZ net官方网站:http://www.wiznettechnology.cn/
或者来电:86-10-84539974(转166),QQ:2377211388,
邮箱:wiznetbj@wiznettechnology.com 联系人:Jerry ,谢谢!

2012年7月4日星期三

WizFiTM – 最易連結乙太網的無線設備


WizFiTM – 最易链接以太网的无线设备
创新的 WLAN AP 模式, WizFi630
WIZnet 将要发布一款符合802.11b/g/n标准的高性能的嵌入式Wi-Fi模块:WizFi630。它使得那些RS-232串行接口嵌入式设备可以通过Wi-Fi更好的接入到TCP/IP网络中。由于其在IP路由功能里有一个开关,WizFi630可以同时作为串口转Wi-Fi设备和AP接入点。
     
· 符合IEEE802.11 b/g/n
· 通信速率: 高达150Mbps (有效速率: 高达 90Mbps)
· 操作方式 : Gateway, AP, AP-Client, Client, AD-HOC
· 接口 : 2 UARTs and 3 Ethernet
· 容易配置 : Built-In Web Server, Serial command, Windows Utility
· 通过CE, FCC, KCC认证
· 欲知更多WizFi630模块详情,请点击这里.
· 若欲采购, 请联系WIZnet官方分销商.样品的采购也可以光顾我们的网络商店:WIZnet e-shop.




WizFi630应用参考
 



· 应用案例 : 4G LTE 中继器
· WizFi630 工作模式 :串口转Wi-Fi & AP接入点
· 为了管理和升级中继器, WizFi630 提供了串口转 Wi-Fi 网关功能. 由于其工作的AP模式下,他也允许笔记本电脑或智能手机在不用附加任何其他AP接入点的情况下就能接入到中继器。


· 应用案例 : 酒店房间控制器
· WizFi630 工作模式 :以太网转Wi-Fi & AP-客户机模式
· 在酒店房间控制系统中, WizFi630工作在 AP-客户机模式下,通过结合Wi-Fi和以太网连接提供了一个多点链接的环境。从而使用户可以通过Wi-Fi或网络进而控制灯光,电视或其他任何电子设备。

如果您有任何疑问,请直接留言或登录WIZ net官方网站:http://www.wiznettechnology.cn/
或者来电:86-10-84539974(转166),QQ:2377211388,
    邮箱:wiznetbj@wiznettechnology.com 联系人:Jerry ,谢谢!

2012年7月3日星期二

參展小結


大家好,我是WIZnet負責網路行銷的Christina。



前幾天有幸在國家展覽館見識了潛在合作夥伴們的技術跟產品。咱們的技術行銷工程師Jerry帶我去參觀了2012第八屆中國(北京)國際動力傳動與自動化控制展覽會與2012第八屆中國(北京)國際煤炭裝備及礦山設備技術展覽會,學習了很多東西回來,受益匪淺,來跟大家分享一下。



展會規模很大,彙集了眾多具有自主智慧財產權的,具備專業化、科技化、國際化領先技術的公司和企業,大多是集生產、研發和銷售的綜合性產品供應商。

隨著科技的不斷發展,煤礦通信系統、井下人員定位系統、監測監控系統等專業技術越來越普及,煤礦、機械行業面對技術更新也有了更多的選擇和機會。隨著產業資訊化的不斷推進,系統的為重工煤炭及礦用裝備解決了地面部門與井下巷道的通信問題,許多公司提出了全套成熟的解決方案。



在展會上,我發現很多煤礦、航太、機械等企業都在根據本身條件的不同情況,運用Zigbee、WiFi、藍牙、3G等不同的無線網路資料通信技術來實現自動控制和遠端控制。越來越多不同的領域也在利用乙太網的功能來更有效的傳輸資料。乙太網就是這種組網的技術規範,根據其工作原理,使用乙太網組網,比以前曾經流行的牌環網變簡單了很多,它很大程度上取代了其他局域網標準,是當今現有局域網採用的最通用的通信協定標準。



顯然,隨著工業自動化對於資料通訊和傳輸的需求越來越強烈,傳統的串口通信逐漸不能滿足日益增長的通訊需求,無線通訊和乙太網技術將廣泛應用於各種自動控制領域。而基於TOE技術的全硬體TCP/IP協定棧晶片及網路單片機已經被眾多自動化行業大量選用,在多個嵌入式領域有著為數眾多的應用。我們一直在關注!關注著行業的發展,專注於為之提供簡易高效,穩定可靠的全硬體乙太網解決方案。

 

如果您有意願與我們合作,或想要深入瞭解我們的產品和技術,可以與我們聯繫,來進行探討和交流。聯繫方式具體如下:

WIZnet官方網站:http://www.iwiznet.cn/

來電:86-10-84539974(轉166)

QQ: 2377211388

郵箱:wiznetbj@wiznettechnology.com 

連絡人:Jerry

2012年7月2日星期一

Integrating Wiznet W5100, WIZ811MJ network module with Atmel AVR Microco...


The rapid penetration of the internet networks into many of today's modern homes and personal gadgets (e.g. smart phone and smart pads) opening a tremendous useful and interesting embedded system application that could be integrated into our house or known as the intelligent house. For more information please visit http://www.ermicro.com/blog/?p=1773

分析稱Google Now性能遠勝蘋果Siri語音助理


7月2日消息,美國科技博客網站Business Insider編輯史蒂夫·科瓦奇(Steve Kovach)周日發表評論文章稱,穀歌Google Now語音數位助理服務性能已遠勝蘋果Siri,且填補了Siri服務此前存在的諸多空白。以下為該文摘要:
在蘋果收購科技創業公司Siri數年之後,大量業界人士認為,此舉為蘋果向穀歌搜索業務發起挑戰而邁出的第一步。這種假設自然有其合理性。
然而在《華爾街日報》旗下博客網站AllThingsD於2010年召開的D8技術大會上,蘋果聯合創始人史蒂夫·約伯斯(Steve Jobs)卻表示,蘋果對於Siri技術的應用與外界想像稍有不同。約伯斯說:“Siri並不是搜索公司,而是人工智慧公司。我們並不希望進軍搜索業務領域,我們不關心這個。其他人(在搜索業務上)做得很好。”
約伯斯上述言論大部分不虛。Siri去年10月被整合到iPhone 4S上面後,該服務更多表現出智慧虛擬助理的特徵,而非一款搜索工具。Siri被設計成一款提醒工具,能夠發送短信並與發出指令等。雖然Siri也部分具有搜索功能,但其搜索結果主要依賴另一家搜索服務商Wolfram Alpha。而Wolfram Alpha又被稱為“知識引擎”,即主要提供事實性資料結果,如“希臘的GPD(國內生產總值)為多少”之類的問題答案,只是此類搜索結果,難以滿足普通公眾的具體需求。
這也就是我對穀歌宣佈推出Google Now感到欣喜的原因所在。Google Now是以搜索業務為中心的語音數位助理,該服務將整合到即將發佈的新款Android 4.1版作業系統當中(開發代碼為“Jelly Bean”)。
過去數天中,我一直在試用運行Jelly Bean的Galaxy Nexus手機和Nexus 7平板電腦。在試用過程中我發現,Google Now的性能表現無疑比Siri更為突出。Google Now填補了Siri服務留下的所有空白,且整體表現也優於Siri。Google Now的表現,其實正是搜索業務如何應用於移動設備上的典型例子。
試舉數例:
上周我在三藩市市報導穀歌的2012年度I/O開發者大會,並在該市採訪了其他數家科技公司。上週五我有一個會議。在會議開始之前45分鐘,Google Now給我發出提醒,並表示我必須趕快出發,否則可能會遲到。Google Now甚至將堵車因素也考慮在內。真不錯。
另一個晚上,我與數名從事新聞行業的老校友聚會。我們當時談論起吉姆·羅梅奈斯科(Jim Romenesko,注:美國科技博客作者)。我的一位朋友當時表示,也不知道羅梅奈斯科現在多大年紀了。於是我將這個問題交給了Google Now,而不到一秒鐘內,Google Now就給出了答案。
我是紐約大都會棒球隊(Mets)的“粉絲”,因此我在穀歌搜索進行的絕大部分體育搜索,多與該球隊的比賽得分有關。Google Now自然也瞭解我的這種習慣,因此會自動向我發送最新賽事的得分情況。我已不再需要向Google Now發出搜索請求。
上週五我乘坐紅眼航班回紐約。在登機前,我與數位朋友一起三藩市Mission區附近聚會。依據我的搜索歷史,Google Now已經知道我的航班號,並向我提供登機入口及航班可能晚點等資訊。
另一方面,Google Now的處理速度很快。數天前我曾同穀歌Android產品主管雨果·巴拉(Hugo Barra)進行過交談。巴拉告訴我,Google Now團隊曾花費數月時間,使Google Now的回應時間縮短數秒鐘。與Siri相比,Google Now提供的資訊不僅相關性更高,且幾乎是瞬間返回答案。就Siri處理速度而言,通常情況下使用者在提出問題後,往往要等上數秒鐘才會得到答案。
Google Now就是我需要的虛擬助理服務。我不想捲入究竟哪款智慧手機性能更好的爭論,我需要得到滿足我個人需求的答案,而Google Now就能做到這一點。有時我甚至不必提問,Google Now就知道我內心所想,真是令人難以置信。
雖然Google Now性能不錯,但Android作業系統碎片化的問題,卻將使得Google Now的推廣事宜面臨著挑戰。穀歌上一個Android版本Ice Cream Sandwich於7個月之前推出,而目前在所有Android設備上的份額僅占7%,即絕大部分Android設備目前仍在運行2010年晚些時候發佈的Gingerbread。
按照這種發展速度,至少還需花上一年時間,絕大部分Android設備使用者才能用上Google Now服務。與此同時,蘋果每個季度會出售大量具有Siri功能的iPhone 4S。即使Siri性能不及Google Now,但大量公眾卻會逐步接觸並熟悉Siri,從而使蘋果在語音助理服務上比穀歌佔據更多市場優勢。
今後Siri的搜索功能肯定會有所加強,我對此深信不疑。只是絕大部分人沒有意識到的是,目前Google Now在性能上已完全擊敗Siri。


如何用W7100A實現HTTP伺服器(二)


大家好,前面我们为大家分享了如何用W7100A实现HTTP服务器(一),今天继续为大家分享后面一部分,希望对大家有帮助~




2.4 程序二进制固件文件生成

利用Keil uVision3程序建立在HTTP服务器应用手册中附带的Keil工程文件。如果成功建立工程,在输出窗口中将会显示如下信息。
图3 成功编译信息
上面信息中的“code=28800”表示输出文件的二进制大小。因为用户将要添加二进制网页,所以这个值必须按照网页二进制的初始地址来设定。这个设置在Keil工程文件romfile.h中,由于十进制数28800用十六进制表示为0x7080,按照下面进行设置。


如果源代码被修改,输出文件的大小也会修改,因此,“FLASH_ROMFILE_START_ADDRESS”定义的大小必须在每次编译后进行修改。如果该定义已经改变,重新编译并且生成一个7100Websrver.hex文件。利用WizISP程序将该十六进制文件变成二进制文件,步骤如下所示。更多关于WizISP的详细信息,请参考‘WizISP用户指南’文档。
图4 WizISP程序

2.5 组合Bin和Rom文件

为了能够将wizweb.rom文件和7100Webserver.bin文件组合成一个文件,将这两个文件移动到allbin.bat文件和allbin.exe文件存在的文件夹下。然后运行allbin.bat文件。allbin.bat文件和allbin.exe文件都包含于HTTP服务器应用手册中的附件文件中。allbin.bat文件通过添加7100Webserver.bin终端的wizweb.rom来创建一个二进制文件。以All_XXXXXX.bin格式创建组合文件。当前的日期会显示在XXXXXX部分。将该文件烧录到WizISP程序中,然后将组合的文件写入到W7100A的代码区域中。程序的组合文件和页面将会被烧录到W7100A中。



3.HTTP服务器演示

如3.5节所述,如果成功创建HTTP服务器的二进制文件,利用WizISP将二进制文件写入到iMCU7100A开发板中。在写入完成之后,将iMCU7100EVB的bootsel引脚变为“off”并且复位开发板。在这篇文档中,使用Windows XP提供的最基本的串行终端程序--超级终端机(Hyper terminal)。在复位之后,超级终端机(Hyper terminal) 将会出现如下信息:


图5 超级终端机(Hyper terminal)信息


iMCU7100EVB的IP地址可以从上面的信息检测到。运行HTTP客户端程序并且连接到开发板的IP地址。在这篇文档中,使用Windows XP提供的基本的HTTP客户端程序—IE浏览器。在输入IP后,将会出现如下的网页。


图6 W7100A HTTP服务器主页面


W7100A HTTP服务器主页面最左上的“Go main” 菜单作为主页面。“Digital Output”菜单用来控制iMCU7100EVB的LED和LCD。“Net Config”菜单用来修改iMCU7100EVB的网络设置。